Hilfe zum Nockenschaltwert

Define the action of a cam switch

To set an iMotion flag during the cam switch is active please select and register a number between 0 and 99. You also can choose one or more digital or virtual outputs.

If you choose an digital or vitual output please don't forget to set theses output to CCOUT = "Drived by rotary switch gear". Here you can see an example for OS03.

Go back


4_CamSwitch

Setup cam gear:

How does it work?

When is it active?

Start and stop position of the cam switch.

Setting the cycle

Setting the number of cam switches

Setting the hysteresis to avoid jitter effects

Cam gear is driven by

Synchronisation of the cam gear to the actual position by iMotion.

Synchronisation of the cam gear to the actual position by digital input

Sending of CAN telegramms

Stopping the cam gear by iMotion or field bus

Stopping the cam gear by digital input

Define the Action of a cam switch

How does it work?

The electronic cam gear works like a mechanic cam gear . The 16 cam switches with its start and stop position can be set in any sequence. Of course, each cam switch has to be shorter than the cam cycle.

For each cam switch an action register can be defined. The action could be e.g. the setting of a digital output or the setting of a flag for the iMotion program.

Go back to the top

When is the cam switch active?

Is the number of cam switches unequal to zero, the cam gear is active.

Go back to the top

Start and stop position of the cam switch

The 16 cam switches with its start and stop position can be set in any sequence. Of course, each cam switch has to be shorter than the cam cycle.

There is no special check.

Go back to the top

Setting the cycle:

After the defined cycle the cycle starts again. The units of the cycle are user-defined (positon control). Is there no special definition of the unit, the unit is increment (speed control).

Go back to the top

Setting the number of cam switches

Only the defined number of cam switches is active. . Is the defined number zero, the cam gear doesn`t work.. There are 16 cam switches maximum.

Go back to the top

Setting the hysteresis to avoid jitter effects

To avoid jitters effects you can define a hyteresis. When reaching the cam switch position the first time, the actual position is stored. Leaving the cam switch at the same position the cam state is reset at the position plus the defined hysteresis off set. Please pay attention, to choose the cam switch length as long as it will be necessary to detect the cam switch according to the speed of the cam gear. (Detection im 1ms-).
It is not allowed to choose the hysteresis length longer than the cam switch length.

Go back to the top

Cam gear is driven by:

There are different possibilities to select the source of the cam gear cycle:

"ENCD [0] = servo position" := The cam gear position is driven by the position of the servo controller

"EGEAR [1] = conducting encoder" := The cam gear position is driven by the position of the conducting encoder

Synchronisation of the cam gear to the actual position by iMotion :

By a positive edge of the iMotion flag 75 the cam switch position will be synchronised to the actual position of the controller.

Go back to the top

Synchronisation of the cam gear to the actual position by digital input:

By a positive edge of the digital input which is defined to "ENCAM (36) Activate rotary switch gear". the cam switch position will be synchronised to the actual position of the controller.

Go back to the top

Sending of CAN telegrams

The cam gear itself doesn't send CAN telegrams. Setting the flag 98 and flag 99 the virtual output OV00 and OV01 you will get an interface to the can routines. Please see also Define the Action of a cam switch

Go back to the top

Stopping the cam gear by iMotion or field bus:

Is the defined number of active cam switches zero , the cam gear doesn't work. You can set the number of by iMotion and field bus (XXXXX)

Go back to the top

Stopping the cam gear by digital input:

The cam gear doesn't work when the digital input which is defined to "start cam gear" isn't set.

To define the action of a cam switch please double click in the column "action".

Go back to the top


Find commutation:

Tuning:
There are five different ways to find the commutation for synchronous motors without absolute encoders. You can choose them in the window "Find commutation. Please choose before the user level 6

Only when control is enabled the first time, the task "find commutation" starts once.

If you want to start it again you have to change one of the parameter, which are used during the initialisation. For example IESEL, ECOFF, CFENC, CFCON ....

Parameter

886-IESEL

Function
Initialise encoder offset by

OFF (0)

Do nothing

IENCC (1)

Current control (with rotor movement )

  1. For the time IENCT[1] a current with the amplitude IENCC[1] in beta- orientation is active
  2. For the time IENCT[0] a current with the amplitude IENCC[0] in alpha- orientation is active
  3. The rotor-position is used for the encoder offset

Error:

After the time of 8100ms IENCT[0] + IENCT[1] a error is set.

LHMES (2)

Inductance test (brake must be active)

The inductance is measured.

Range of use:

Motors with active brake, motors with huge inertia J

Tuning:

  1. IECNT[2] test signal periodic time.
    (Setting 3 means 1/3ms = 333Hz test signal frequency)
  2. IENCCT[2] test signal altitude[A]

The following parameters are determined during commutation finding:

Parameter Meaning Unit
SC_V0[0] Rotor position in I=[-180..0] grd
SC_V0[1] Rotor position in I=[0..180] grd
SC_V0[2] Rotor position in I=[-180 .. 180] grd
SC_V0[3] Rotor position in I=[-0,5 .. 0,5] 1
SC_V1[0] Last measured value for [image] W
SC_V1[12] [image] (Mean value [image]) W
SC_V2[0] Last measured value for [image] H
SC_V2[3] [image] H
SC_V2[4] [image] H
SC_V2[10] [image] H
SC_V2[11] [image] H
SC_V2[12] [image] (Mean value [image]) H

IECSC (3)

Oscillation analysis (small movement, in preparation)

Attention – WARNING – only prototype

Only for use for well trained persons

Tuning:

1. IECNT[3] ] test signal periodic time.
(Setting 3 means 1/3ms = 333Hz test signal frequency)
  2. IENCT[3] test signal altitude[A]

Default settings:
If you set the parameters to 0, the default settings are used :

IENCT[3] = 10ms, IENCC[3] = 0,2 * MOCNM*SQRT(2)

IECON (4)

With minimised movement

A well tuned speed control setting is necessary
  • During the time IENCT[1], the current is rised up to IENCC[1] via a ramp.
  • Afterwards, during the time IENCT[0], the current is rised up to IENCC[0] via a ramp.

The rotor must stand still at the end of each ramp. The target of the optimisation is the minimisation of the rotor movement at the end of each ramp.

You can use the scope to measure the movement. Therefor have a look for the values eps_RS (rotor position) and the current in the d-direction (isd_ref, isd)

Default setting: Therefor set all parameters to zero.

HALL1 (5)

Hall-sensor two sensors which are fixed at the stator in a distance of
120 degree are used:

The two sensors deliver analogue sin-cos-signals.

The sensors are connected to the slot X5 at the device. The encoder offset is calculate with these signals (arcus-tangens).

The precision depends upon the quality of the magnetic field and the quality of the analogue signals.

HALL2 (6)

Hall-sensor two sensors which are fixed at the stator in a distance of
90 degree are used:

The two sensors deliver analogue sin-cos-signals.

The sensors are connected to the slot X5 at the device. The encoder offset is calculate with these signals (arcus-tangens).

The precision depends upon the quality of the magnetic field and the quality of the analogue signals.